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Getting Started 

Installing Business Process Visual ARCHITECT (BP-VA) 

1. Run the BP-VA installer after your download it.  

 

2. Click Next on the welcome page. This will bring you to the License Agreement page. 

3. Read through the license agreement. Choose I accept the agreement after you finish reading the 

agreement and fully understand and accept the terms.  Click Next. 

4. Specify the directory for installing BP-VA. Click Next to continue. 

5. Select the location for the start menu folder, under which you will find the program’s shortcut. Click Next. 

6. Decide on whether to enable your system to recognize .vpp project files and .zvpl key files. If enabled, you 

will be able to open the file in the appropriate application directly by double clicking it. Keep both .vpp and 

.zvpl associations checked and click Next. 

7. Select the edition of BP-VA you want to install. Click Next to start the file copying. 

 

8. Once the file copying is finished, you can choose to start BP-VA immediately, or just finish the installation 

without starting BP-VA. Choose the option Don't Start and click Finish. This will end the installation of 

BP-VA. 

Starting BP-VA 
Start BP-VA from the shortcut in the Start menu. If you selected not to create an entry in the Start menu (during the 

installation), you can look under the installation folder of BP-VA (the same path specified in step 4 in the section 

above) and start BP-VA by running the launcher in the launcher folder. 
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Selecting a Workspace 
When you start BP-VA, you need to specify a folder for workspace. A workspace is a folder in which application 

preferences, like the look-and-feel settings, are stored. 

 

You need to select a workspace every time you start BP-VA but the workspace selected need not always be the 

same. If you want to keep applying the same set of preferences, always start BP-VA with the same workspace 

folder. If you are moving to a new machine and want to keep the application preferences, simply copy the 

workspace folder over and choose it as workspace when starting BP-VA on the new machine. If you want a fresh 

working environment, select a new folder and proceed. Now, select any folder you like and click OK to continue. 

Importing License Key 
After you select a workspace, the Key Manager will open, asking you for a valid key to 'unlock' BP-VA. Depending 

on whether you own a purchased copy or an evaluation copy of BP-VA, you can get the key by following the steps 

below: 

For customers 

If you purchased a copy of BP-VA, you should receive our notification (Email) with an activation code. The same 

activation code can also be found from the license key listed in your customer account. Copy the activation code. 

  

Click on Input activation code and paste the copied activation code in the dialog box.  

 

For evaluators 

For evaluation copy of BP-VA, you can click either Try without key or Request key. Choosing Try without key 

enables you to evaluate BP-VA for 10 days. To evaluate for 30 days instead, choose Request key and sign in. If you 

are not our member yet, fill the Registration form to register. After you sign in and make a request, you will receive 

the key file via email. 
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Environment 

 
In the BP-VA environment, you will see areas such as the Menu bar, Toolbar, Diagram Navigator, Property pane, 

Message Pane and Diagram Pane. The following table provides more details about each function. 

1 Menu bar The menu bar at the top of the window allows you to select and perform various 

operations in BP-VA. 

2 Toolbar  The toolbar is below the menu bar. It is an extension of the menu bar. All buttons are 

presented in groups of icons which are readily accessible. 

3 Diagram 

Navigator 

An area in which diagrams are listed and grouped by their type. You can access 

existing diagrams as well as creating new ones here. 

4 Properties Pane An area in which properties of the shape currently selected is displayed. 

5 Message Pane An area displaying information or warning from the system, if any. 

6 Diagram Pane An area in which diagrams are displayed. 
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Saving and Opening Projects 
To save your work, select either File > Save Project or File > Save Project as…. When you are saving a project 

for the first time, you will be asked to specify the location. You can save the new project either in your current 

workspace or a directory of your choice. 

 

To open an existing project, select File > Open Project… from the main menu and select the project to open. 
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Diagramming 
After you familiarize yourself with the BP-VA environment a little bit, you are ready to learn how to create a 

diagram. In showing how to create diagrams, we will also talk about how to create, format, document and connect 

diagram elements (shapes). 

Creating a Diagram 
To create a diagram, say a business process diagram: 

1. Right click Business Process Diagram in the Diagram Navigator and select New Business Process 

Diagram. 

 

2. Name it Sales order system. 

 

Creating Shapes 
To create a shape in your diagram, select the shape type you want from the Diagram Toolbar. In the diagram, click 

once and drag to resize the shape. Release the mouse button when you are happy with the dimensions. Let’s say we 

want to create a task. 

1. Select Task from the diagram toolbar. Press in the diagram and then start dragging. Release the mouse 

button when you are happy with the shape’s size. 

 

2. Name the task get an order. Press Enter to confirm the name.  
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Connecting Shapes  
You can connect two shapes by making use of the resource icons surrounding a shape. Let’s say we want to 

associate a task with another task. Place your mouse over the task. Click the Sequence/Message Flow -> Task 

resource icon around it and drag it to another task. Release the mouse button. 

   

Documenting Model Elements 
You can enter a description for your shape in the Documentation Pane at the bottom left of the screen.  

  

In addition to the form of text, you can also voice-record a description. Click the Record button at the bottom of the 

Documentation Pane. In the Record Voice dialog box, start recording by clicking the red circle button and stop 

recording by clicking the button with a square inside. To save your recording, click OK. 

 

Note Make sure your recording device is available in order to use this feature. 

Formatting Shapes 
You can format a shape according to your preference by right clicking it to select Styles and Formatting and then 

Formats… from the popup menu. Let’s say we want to change a task’s background color. 

1. Right clicking on the task and select Styles and Formatting and then Formats… from the pop-up menu. 
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2. In the Formats dialog box, select a color such as Pink in the Background tab and click OK to confirm the 

change. The task should appear in pink now. 

 
 

As another example, let’s format a connector’s style. 

1. Right click a connector and select Styles and Formatting and then Formats… from the pop-up menu. 

2. In the Formats dialog box, select Gray for line color and click OK to confirm. As a side note, the option 

Weight is used to alter the thickness of the connector. The higher the value in Weight, the thicker the 

connector will become. 
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Business Process Modeling 

Drawing a Business Process Diagram 
Generally speaking, business process diagram is primarily made of activities such as tasks and sub-processes. They 

both represent work that an organization performs in a business process. As an example, we will show you how to 

create a business process diagram which illustrates how to place an order in a restaurant. 

1. Select Start Event from the Diagram Toolbar and click once in the diagram to place it. 

 

2. Place your mouse pointer over the start event. Click and drag the resource icon Sequence Flow -> Task. 

Release the mouse button when you reach the location you want for the task. Name the task Read Menu. 

 
3. Place your mouse pointer over the Read Menu task. Click and drag the resource icon Sequence/Message 

Flow -> Gateway. Release the mouse button when you reach where you want to place the gateway. Name 

it Leave?. 

4. Place your mouse pointer over the Leave? gateway. Click and drag the resource icon Sequence/Message 

Flow -> Sub-process. Release the mouse button when you reach where you want to place the sub-process. 

Name it Order Meal. Double click the line linking Leave? and Order Meal to name it No. Place your 

mouse pointer over Leave?. Click and drag the resource icon Sequence/Message Flow -> Task. Release 

the mouse button when you want to place the task there. Name the task Leave. Double click the line linking 

Leave? and Leave to rename it Yes. 

5. To create an end event, place your mouse pointer over Order Meal. Press and drag the generic resource 

icon. Release the mouse button when you reach the desired place. Select End Event> End Event from the 

pop-up menu. Repeat to add an end event from the Leave task. 

6. Define the Order Meal sub-process by clicking the plus button in it. 

 
7. In the new business process diagram opened, you can model the details of the sub-process. After you finish 

editing, you can return to the original diagram by clicking the Order Meal link in the top left corner. 

 
8. Back in the original diagram, the plus button inside Order Meal will turn into a minus button. 
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Writing Operating Procedure 
The necessary procedure to handle a task can be specified by filling in the operating procedure. In the following 

example, we will show you how to do that. 

1. Create a task called lookup parcel and click on it to enable the procedure editor below the diagram. If the 

editor does not show up to begin with, right click on the background of the diagram and select Show 

Procedure Editor in the pop-up menu. 

 

2. In the first row, enter Get the tracking number from the parcel owner for the first step. Then press Enter to 

move to the second step. Enter Lookup the parcel with the tracking number and press Enter. For the third 

step, enter Bring the parcel to the counter. 

  

Animating a Business Process 
[Simulacian only] 

Animacian is a feature that allows you to animate a business process. The ability to present your ideas in a dynamic 

way could help your clients understand your design better. 

1. Draw a business process diagram like this: 
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2. Select Modeling > Animacian… from the main menu or select Modeling > Animacian… from the 

toolbar. 

 

3. In the dialog box opened, select the path to be executed and then click Play.  

 

Simulating a Business Process 
[Simulacian only] 

Simulacian is a set of tools that allow you to record and study the resource consumption in a business process, 

monitor the duration of activities and identify bottlenecks. And these study results would, in turn, help improve a 

process. 

1. Draw the following business process diagram X-Ray Inspection: 

 

2. Right click on the diagram background and select Diagram Type > Simulacian from the popup menu. 
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3. In the Simulacian Control Panel, click Add under Available resources to add a resource called X-Ray 

Machine (Machine for type and 1 for amount). 

 

4. Select the Register task in the diagram. In the Simulacian Control Panel, enter 2 m for duration. 

 

5. Repeat the previous step to set Perform Inspection's duration to 15 m. 

6. Select the Patient pool. In the Simulacian Control Panel, enter 1 for instance. Use similar steps to set 

Doctor's instance to 1. 

7. Click on Show Inputs in the Simulacian Control Panel. 

8. Under Inputs, click Add to add an input named Peak hour. Enter 5 for instances. 

 

9. In the Simulacian Control Panel, set the scale to 10 Mins scale. 

 

10. Click Start. 
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11. Study the simulation outcome. The green running circle represents a task in execution, while the red 

inverted triangle symbolizes pending jobs and shows a number indicating the number of jobs pending. 

 
You can see that the bottleneck occurs in the Perform Inspection task. In order to improve this process, you 

can employ more doctors (by increasing the instance of pool Doctor) and buy more X-Ray Machines (by 

increasing the amount of resource X-Ray Machine). 

Constructing As-Is and To-Be Processes 
[Analyst Edition or above] 

The current business process can be modeled, and then be transcribed into a to-be adopted process by making use of 

model transitor. You can even trace the changes that have been made using visual diff. 

1. To construct an as-is process, right click on the background of the Model Explorer and select Model > As- 

is Process. 

 

2. To create a new business process diagram based on the as-is process, right click As-is-Process and select 

Diagram > Business Process Modeling > Business Process Diagram. 

 

3. Name the diagram As-is Process and develop it to an inspection procedure diagram as shown below. 
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4. Right click on the diagram and select Utilities > Transit to New Diagram… to transit it to a to-be process. 

 

5. Click New Model in the Select Parent Model of New Diagram dialog box and type in the name To-be 

Process in the pop- up Model Specification dialog box. Click OK in both dialog boxes to confirm. 

 

6. In the to-be process diagram, rename the Issue warning letter task to Send Inspection Report. Use the 

resource centric interface to jump back to as-is process to review the change.  

 

7. The visual diff tool helps you to review the changes between models. Select Modeling > Visual Diff… 

from the main menu to start visual diff. 
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8. In the Visual Diff dialog box, select Transitor for Strategy and Model Element for Compare. Check the 

checkbox for Use Working Project and select To-be-process for Diagram in the right section. Model 

elements that have been modified will appear at the bottom of the dialog box. 
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General Business Modeling 

Working with Glossary 
[Analyst Edition or above] 

Glossary is a documentation tool that allows you to define and manage domain-specific terms by defining their 

meanings and aliases. 

1. To begin, select Requirement > Glossary Grid from the toolbar. 

 

2. To create a term, click the Create Term (Insert) button at the top of the Glossary Grid. Right click the 

newly created term and select Open Term Editor. 

 

3. Click Add to insert an alias for the term. In the Definition section, type in the meaning of the term. 
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Drawing a Fact Diagram 
[Simulacian only] 

Apart from glossary grid, you can even model business vocabularies as well as the relationships between them by 

forming a fact in a fact diagram.  

1. To create a fact diagram, right click on Fact Diagram in the Diagram Navigator and select New Fact 

Diagram from the popup menu. 

 

2. To create a term in the diagram, select Term from the diagram toolbar and click on the diagram.  

 

3. To describe a term, right click on the term and select Open Term Editor. Note that you are not allowed to 

rename a term directly through inline editing. 

 

 



Business Process Visual ARCHITECT Quick Start 

Page 19 of 32 
 

 

Drawing a Process Map Diagram 
[Analyst Edition or above] 

Process Map Diagram is supported as one of the business process modeling diagrams in BP-VA. This section will 

show you how to insert a sub-diagram in a process map diagram. 

Let’s say we want to add a BPD sub-diagram. 

1. Draw a process map as shown below. 

 

2. Hover your mouse over Send assignment to the tutor and click the Sub Diagrams resource icon. Select 

Add > Other Diagrams > Business Process Diagram from the pop-up menu. 

 

3. A new business process diagram will open for you to put in the details. 
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Drawing an Organization Chart 
[Analyst Edition or above] 

An organization chart is a graphical representation of an organization’s structure. It is usually drawn and read from 

top to bottom.  To create one, select Organization Chart > New Organization Chart in the Diagram Navigator. 

It will open a new organization chart diagram with a unit in it to start with. Enter a name for the new diagram and 

the unit. 

 

We are going to use the structure of ABC Company as an example in the following steps. The top node is Executive 

Director as the first level management. The second level management includes Sales Manager and Marketing 

Manager and the third level is made up of Salesperson and Marketing staff. The lines in the organization chart show 

the relationships between staffs. 

1. Name the newly created unit Executive Director. Hover the mouse over the Executive Director unit and 

press its resource icon New Subordinate.  

 

2. Name the newly created subordinate Sales Manager. To add a new coworker, hover your mouse over the 

Sales Manager unit and press its resource icon New Coworker. Name it Marketing Manager. 

 

3. To finish it, create subordinates Salesperson and Marketing staff for Sales Manager and Marketing 

Manager, respectively. 
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Report Generation 

Customizing Report Templates 
[Analyst Edition or above] 

In addition to using built-in templates, you can also design and customize your own report templates. 

1. In the Generate PDF/ HTML/ Word dialog box opened, select New in the Template drop down menu. 

 

 

2. In the Report Template dialog box opened, type in a name for your report template and start editing. For 

example, click Add Diagram Loop below the name to create a loop of specific type(s) of diagrams. 

 

3. A tree will appear on the right hand side of the Report Template. Select Business Process Diagram and 

click the green right arrow to insert it to the loop. 

 

4. Click the Add Diagram Image icon on the left hand side of the Report Template. Click the Add Element 

Summary on the Diagram Loop (Business Process Diagram) icon to insert a summary table to the 

diagram. 

 

5. Select the elements that you want to include on the right hand side and press the right arrow to insert it to 

the included element list.  

6. Click the Add Property Column button from Element Summary to insert a property. Select 

Documentation from the right hand side and Documentation ${value} will show on the left hand side. 

Click the Add Property Column Below icon on Documentation ${value}.  

 

7. Select other desired elements on the right hand side following the steps mentioned above. 

8. After you have finished defining the template, click the Save button. You can then return to the Report 

Generation dialog box and select the template from which to generate report. 
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Publishing Report to a Website 
1. You can publish your report to a website by selecting Tools > Project Publisher… from the main menu. 

 
2. Enter the output path in the Project Publisher dialog box and click OK to publish. 

3. It will then publish the current project and open the published content in a web browser. You should see 

three tabs: Diagram Navigator, Model Explorer and Logical View on the left and the actual diagram on the 

right. After you select a diagram in the Diagram Navigator, it will appear on the right. 
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4. You can click on a shape (e.g. a task) on the image to enter its detail page to read its properties. 
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Teamwork Collaboration 
Through the teamwork collaboration feature, your team can work together on the same project in parallel 

effectively. BP-VA supports the integration with version control systems such as SVN, CVS, Perforce and 

Teamwork Server. In this section, we will cover basic setup of Teamwork Server (which SVN, CVS and Perforce 

users can skip) and basic teamwork operations with Teamwork Server. Techniques covered here can be applied to 

the integration with SVN, CVS and Perforce as well. 

Login to Server  
We will begin by logging to the Teamwork Client in BP-VA. 

1. In BP-VA, select Teamwork > Open Teamwork Client... from the main menu. 

2. In the Login dialog box, enter 127.0.0.1 for server host, john for name and a password. (You can follow the 

instructions from the last section). Click OK. 

 

3. In the Manage Project dialog box, select My Project and click >. Click OK. 
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Checkout and Open Projects 
Checkout project means downloading a project from server to your computer. Open project refers to opening the 

downloaded project in BP-VA. 

1. In the Teamwork Client dialog box, click Checkout at the bottom right corner of the dialog box. 

 
 

2. Click Open Project. 
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Commit Local Modifications 
Committing local modifications refers to the process of uploading local modifications to server. 

Create a simple business process diagram as shown below. 

 

1. Select Teamwork > Commit... from the main menu to commit your changes to server. 

2. The Commit dialog box displays the changes to be committed to server. Click Next to proceed. 

 

 

 



Business Process Visual ARCHITECT Quick Start 

Page 27 of 32 
 

Update Server Changes to Local 
Update server changes to local refers to the process of getting or downloading changes others have committed to 

server. 

1. Ask another team member to start BP-VA on his/her computer. 

2. Follow the steps listed in the Login to Server section to login to server as user peter. 

3. Checkout and open project My Project. 

4. Open the business process diagram, and rename the task. 

 

5. Follow the steps described in the Commit section to commit the changes to server. 

6. Now, go back to john's environment. 

7. Select Teamwork > Update... from the main menu. 

8. The Update dialog box displays the changes to be updated from server. Select Diagram > Business 

Process Diagram1: BusinessProcessDiagram > Place Order : BPTask. Click Compare. This is to 

preview the changes before the actual update. In the event that the changes are not desirable, you can click 

Cancel to abort the process. Click OK. 

 

9. Check the task. Its name should have been changed to Place Order. 
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File Referencing with Teamwork Support 
When modeling, there may be external resources you want to attach to a model which help describe it in details or 

include data that cannot be modeled, like a text document. You can do this by adding file references to models. If 

you are working in a team-based environment with Teamwork Server, you do not need to copy any referenced files 

over for other team members to open. Instead, you could commit your model along with the referenced files to the 

server. 

1. Open the Teamwork Files pane in the panes group at the bottom left of the user interface. 

2. Drag a file to the Teamwork Files pane.  

 

3. Click OK when you are asked to confirm putting the file to workspace. You must click OK here. 

Otherwise, the file won't be added as a teamwork file nor committed to server. 

4. Select Tools > Application Options from the main menu. 

5. In the Application Options window, select User Path on the left hand side. 

6. On the right hand side, click Add... and select Project Files Path from the popup menu. Click OK at the 

bottom of the Options window to close it. 

 

7. Move the mouse pointer over the Place Order task to show the resource icons. 

8. Click on the References resource icon at the bottom left of the requirement shape and select Add File... 

from the popup menu. 

 

9. In the Task Specification window, click on the ... button next to the Path field. 
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10. Click on the Project Files Folder shortcut. Note that if you have not completed steps 4 to 6, you will not 

see this shortcut. 

 

11. Select the teamwork file and click Open at the bottom right to choose it. 

12. Click OK in Task Specification to return to the diagram. 

13. Commit the changes to server. Note that the commit action will bring along the teamwork file(s) to server. 

You may check it in the Commit window.  
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Advanced Modeling 
 

Using Nicknamer 
[Analyst Edition or above] 

“Nicknamer” is a feature which helps you to set up and manage multiple language sets for a model. For example, if 

a multinational corporation needs to present models in several languages to local staff, this feature proves to be 

particularly useful. While the default language set (or “nickname”) is English, you are free to add others, such as 

Traditional Chinese in the following example. 

1. Select View > Nicknames > Configure Nicknames… from the main menu. 

 

2. In the Configure Nickname dialog box, click Add User Language and select Chinese (Traditional) in 

the Add User Language dialog box and then click OK. Finally, click OK to go back to the diagram and 

start working with the Chinese version of the model.  

  

 

Note To change the nickname back to English, select View > Nicknames > Original from the main 

menu. 
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Layers 

Layer is a feature that lets you divide shapes on a diagram into logical groups and perform various actions on them 

including changing their visibility and disabling user edits.  

1. You can create a new layer by selecting View > Layers… from the main menu. 

2. In the Diagram Layers dialog box, click on the Create new layer button. Name the new layer Annotation 

Layer and then click Close to confirm the addition. 

 
3. You can move a shape to another layer by right clicking on it and selecting the layer to which it moves. For 

example, you might want to move a callout from the current layer to another defined specifically for 

annotations by right clicking on the callout shape and selecting Annotation Layer. 

 

You can choose to show/hide model elements or disable edit for them by layer. To do that, in the Diagram Layers 

dialog box, specify your choice by checking/unchecking the Visible and/or Locked columns, respectively.   
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Splitting a Diagram View 
Instead of scrolling back and forth, BP-VA can split a diagram vertically or horizontally for you to view different 

parts of a huge and complicated diagram effectively. 

 

Below are the steps to split a diagram view. 

1. Move your mouse over the left vertical bar on the bottom slider. You should see a double arrow over it. 

Then move the slider to the right. 

 

2. Release the mouse when you reach about half way through the diagram horizontally. 

 

 

 


