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Getting started 

Installing Visual Paradigm for UML (VP-UML) 

After you have downloaded Visual Paradigm for UML from our website, the next step you should do is to install it. 

The following steps are going to teach you how to install it: 

1. Double click the downloaded installer file to execute it, then click Next button to go to next page. 

  

2. Go through the License Agreement. Choose I accept the agreement after you finish reading the 

agreement and fully understand and accept the terms, and then click Next. 

3. Select the destination you want VP Suite to be installed, and then click Next. 

4. Select the location you want the Start Menu folder to be placed, which is the location where the program’s 

shortcut is, under the Start menu. Click Next. 

5. Select the file associations that you want to create.  

6. Place a tick to select Visual Paradigm for UML (VP-UML), and then click Next. 
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7. Fill out the Products Configuration. Select the edition you have purchased or you want to evaluate, then 

click Next.  

 

8. Fill out the Products License. It is optional that you can fill in or just ignore it, then click Next. 

Note If you put the key and installer file in the same folder, it’ll automatically fill the key address for 

you in file path. Wait a few seconds for installing and checking system environment. 

9. The installation has been completed. You can choose either to start it now by clicking Visual Paradigm 

for UML 7.1 and then click Finish or start it later on by clicking Don’t start. 
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Starting Visual Paradigm for UML 

You can start Visual Paradigm for UML by selecting Start Menu > Visual Paradigm > Visual Paradigm for 

UML 7.1 Enterprise Edition. 

Importing license key 

1. After you enter VP-UML, you will be asked to provide license key in License Key Manager.  

 

a) If you have purchased VP-UML, you should have the permanent license key. Click Import key to 

import your permanent license key in Key Manager. 

 

b) For evaluation, please click either Try without key or Request key. Choosing Try without key 

provides 10 days evaluation period without input your email while choosing Request key lets you 

request for an evaluation key that allows you to evaluate 30 days. If you are our member, you will be 

asked to sign in after you click Request key. If you are not our member, you should register as a 

member on Internet by filling the Registration form. The key will be sent to your email account 

automatically after you have signed in.  

Note If you are running the Community Edition, you can either try VP-UML for 1 hour without key, 

or request for a key that enables you to run permanently. 
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Selecting workspace 

Workspace is a directory that can memorize your own setting and preferences.  You will be asked to select a 

workspace every time you start VP-UML. If you would like to keep the application settings, always start with the 

same workspace. When you move to a new computer, you just need to copy the workspace, and then all settings will 

be kept. If you want to have a fresh working environment, start with a new workspace. 

 

Environment 
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Menu bar, Toolbar, Diagram Navigator, Property pane, Message Pane and Diagram Pane are shown on the 

environment of VP-UML window. The brief introduction of each function shows in the following table: 

1 Menu bar The menu bar at the top of the window allows you to select and perform various 

operations in Visual Paradigm for UML. 

2 Toolbar Toolbar, which is below the menu bar, is the extension of menu. All buttons are 

presented as groups of icons that handily placed for users. 

3 Diagram 

Navigator 

A place where diagrams are listed, and where you can create and access diagrams base 

on their types. 

4 Properties Pane The properties of chosen model/ shapes will be shown on properties pane upon 

selection. 

5 Message Pane Possible information or warnings will be shown here. 

6 Diagram Pane The diagram will be displayed in diagram pane. 

Saving and loading projects 

To save your work, select either File > Save Project or File Save Project as…. When you perform saving the 

first time, you can select to save the project in workspace, or to another directory you preferred. 

 

To load an existing project, select File > Open Project… from the main menu and select the project to load. 
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Diagramming 

After you are familiar with the environment of Visual Paradigm, you should get to know how to create a diagram. 

This chapter is going to teach you not only how to create diagrams, but also how to create and connect diagram 

elements (shapes), documents their details, how to format them and a general description on the nickname and layers 

feature. 

Creating diagram  

To create a diagram say, a use case diagram: 

1. Right click Use Case Diagram in Diagram Navigator and select New Use Case Diagram. 

 

2. Enter the name for the new diagram as Sales order system after creating it. 

 

Creating shapes 

To create a shape, select the type of shape from the diagram toolbar, click on diagram and start dragging it to create 

with a preferred size. Taking creating use case as an example: 

1. Select Use Case from the diagram toolbar, click on the diagram and then start dragging. Release the mouse 

to confirm creation. 
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2. Enter the name for the use case as place order and press enter to confirm the name. 

 

Connecting shapes  

Two shapes can be connected by making use of the resource icons surrounding a shape. Let say if we want to 

associate an actor with a use case, move the mouse pointer towards the actor, press on its Association resource icon 

and drag it to the use case, finally release the mouse button. 

     

Documenting model element 

You can type in the textual description to your shape by opening the Documentation Pane at the bottom left of 

screen and typing in the space provided.  

 

In addition to text description, you can describe by voice through recording. Click the Record button at the bottom 

of Documentation Pane. In the Record Voice dialog box, start recording by clicking the red circle button and stop 

recording by clicking Stop button. To save your recording, click OK. 

 

Note Make sure your recording device is available in order to apply this feature. 
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Setting color, line and font styles for shapes 

You can format a shape with your preference by right clicking on it, selecting Styles and Formatting and then 

Formats… from the popup menu. Taking changing the use case’s background color as an example: 

1. Right clicking use case and select Styles and Formatting and then Formats… from the popup menu. 

      

2. In the Formats dialog box, select a color such as green in the Background tab and click OK to confirm 

the change, the color of use case will be changed into green.  

 
 

Formatting the connector style as another example: 

1. Right click a connector and select Styles and Formatting and then Formats… from the popup menu. 
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2. In the Formats dialog box, select blue as line color and click OK to confirm. As a side note, the option 

Weight is used to alter the thickness of the connector. The higher the value in Weight, the thicker the 

connector will become. 

 

 

Using nickname  

Nickname is a feature which helps you to set up and manage multiple language sets of a model. The original 

nickname is defaulted as English. You can add a new nickname for example, Chinese: 

1. Click on the dropdown menu Original on toolbar and choose Configure Nickname. 

 

2. In the Configure Nickname dialog box, click Add User Language and select Chinese (Traditional) in 

the Add User Language dialog box and then click OK. Finally, click OK to go back to the diagram and 

start working with the Chinese version of model.  

     

Note This feature is only available for Standard Edition or above. 

 

Note To change the nickname back to English, choose the option Original in the drop down menu of 
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nickname. 

Layer 

Layer is a feature that lets you divide shapes on a diagram into logical groups, and perform various actions including 

changing their visibility, and disabling the editing on them.  

You can create a new layer by selecting View > Layers… from the main menu. In the Diagram Layers dialog box, 

click on the Create new layer button. Name the new layer as Annotation Layer and then click Close to confirm the 

change. 

 

A shape can be moved to another layer by right clicking on it and selecting the layer to be moved to. For example, a 

callout can be moved from the current layer to a new layer specialized for annotation by right clicking on the callout 

shape and selecting Annotation Layer.  

 

Visibility and accessibility of a layer, or we say the shapes on a layer, can be controlled by opening the Diagram 

Layers dialog box, and checking/un-checking the Visible or Locked columns of the corresponding layer. Note that 

a locked layer will result in making shapes on that layer not selectable or movable. 
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UML modeling 

Drawing use case diagram 

Use case diagram is designed for modeling the context of a system. In a use case diagram, all stakeholders and 

system goals are identified to elaborate how a system is formed. The main elements of use case diagram include use 

case, actor and association (communication link).  

The following simple use case diagram illustrates the basic requirements of enrolling in an overseas university. The 

actor Student represents the role of student while apply for student visa online, take a physical examination and pay 

tuition fee are three goals that the student can achieve. You can create actor Student from diagram toolbar, and the 

three use cases from the resource icon Association -> Use Case of actor. 

 

Documenting use case details 

Apart from naming a use case, you also can document its detail. Right click on a use case, such as apply for student 

visa online and select Use Case Details…. In the Info tab, fill in the Rank, which presents the importance of this 

use case. 

 

Furthermore, you can provide the procedure of attaining the goal of the use case in Flow of Events. Open the Flow 

of Events tab and type in the procedure step by step. Below are the procedures of applying for student visa online. 

Firstly, click in online system homepage; secondly, enter personal details; thirdly, provide credit card details and 

finally click confirm. Enter them one by one in the flow of events editor, like what the image below shown. 

 

Note The function of use case detail is only available for Professional Edition or above. 
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Building project glossary from flow of events 

Glossary is a place where domain-specific vocabularies are stored and managed. Instead of adding terms 

(vocabularies) from your imagination, you can develop a glossary by identifying terms from flow of events.  

1. Suppose online system homepage in a step of flow of events is a key phrase. Select it in flow of events, 

right click and select Add ‘online system homepage’ to Glossary from the popup menu to extract this as a 

term. 

 

2. This opens the glossary with term online system homepage added. Right click on the term and select Open 

online system homepage Specification…. 

 

3. Try to specify its alias. In the Term Specification dialog box, click Add and enter official site as the first 

alias. Repeat to add alias main page.  Enter description of the term in Documentation. Finally, click OK to 

finish editing. 

 
 

Note Move you mouse pointer to the underlined term online system homepage in Flow of Events, the 

documentation of the term will reveal automatically. 

 

Note If you want to open the closed glossary, select Tools > Model Elements Grid > Open Glossary 

Grid from the main menu. 
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Drawing sequence diagram 

A sequence diagram is used primarily to show the interactions between objects that are represented as lifelines in a 

sequential order. More importantly, lifelines show all their points of interaction with other objects in events. A 

sequence diagram can be created by right clicking Sequence Diagram on Diagram Navigator and then selecting 

New Sequence Diagram from popup menu. 

Taking the use case of apply for student visa online as an example: 

1. Select Actor from the diagram toolbar to create an actor. Name it as Student. 

 

2. Press on the resource icon Message -> LifeLine and drag it into the location you prefer to create a lifeline 

with interaction to actor Student. Name the lineline online system, and the message in between enter 

personal details. 

 

3. Repeat the previous step to create a lifeline database from online system.  
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Drawing activity diagram 

An activity diagram is essentially a flowchart, showing flow of control from one activity to another. Unlike a 

traditional flowchart, it can model the dynamic aspects of a system because it involves modeling the sequential steps 

in a computational process. A new activity diagram can be created by right clicking Activity Diagram on Diagram 

Navigator and then selecting New Activity Diagram. 

Taking using an ATM as an example: 

1. Select Initial Node on diagram toolbar and drag it to the diagram pane.  

    

2. Create an action through the resource icon Control Flow -> Action of initial node. Press on the icon and 

drag to the target position.  

 

3. Name the action as insert card. 

 

4. Terminate the activity by creating an activity final node through the resource icon Control Flow -> 

Activity Final Node of the final action. 

 

5. You can use swimlane to group actions based on the participants involved. Select Horizontal Swimlane 

from the diagram and drag it on the diagram pane to create it. Double click the head of the partitions and 

name them as user and ATM system respectively. You can then move shapes into the appropriate partition. 
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Drawing class diagram 

A class diagram shows the blueprints of objects required by a system and the relationships between them. A new 

class diagram can be created by right clicking on Class Diagram on Diagram Navigator and then selecting New 

Class Diagram from the popup menu. 

Taking bank account as an example: 

1. Select Class on the diagram toolbar and drag it to the diagram pane. 

  

2. Name the class as bank account. To create an attribute, right click the class and select Add > Attribute 

from the popup menu. You can create as many as attributes as you need by pressing enter after adding a 

new one.  In the class of bank account, create attributes name and balance. Similarly, operation can be 

created by right clicking the class and select Add > Operation from the popup menu. Create operations 

debit and credit. 
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3. Generalization is needed when you want to show the subclass out of the super class. It can be created by 

pointing the super class, selecting the resource Generalization -> Class and dragging it to the place you 

want the subclass to appear. 

 

4. Create two subclasses and name them as saving account and term deposit account. Add InterestRate and 

depositMonthlyInterest as attribute and operation of class saving account, and add PeriodInterestRage and 

initialDeposit as attribute and operation of term deposit account. 

The following figure is the completed class diagram: 

 

A class can be associated through the help of resource centric interface. Move the mouse cursor over the class 

student. Press on the resource icon Association -> Class and drag to another class school. 

 

To edit an association or its ends, double click on it or either of its ends to open the Association Editor. Name the 

role of association end by typing it in the middle text box and adjust the properties like multiplicity and navigability. 
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Code generation 

Code generation is the process by which code generator generates source code from UML class model. By editing 

the generated code by filling in the code logic, a fully completed application can thereby be set up. 

Java round-trip 

 

Round-trip engineering enables you to keep class model and source code in-sync. With Java round-trip, you can 

reverse a code-base to VP-UML as class model, analyze, and make changes such as to add missing classes, and then 

update the changes to code, or vice versa.   

 To generate Java source code from class model, select Tools > Java Round-trip > Generate Code… from 

the main menu. Enter the output path in the Generate code dialog box and click OK to generate. 

 

 To reverse class model from code, select Tools > Java Round-trip > Reverse Code… from the main 

menu. The Reverse code dialog box will be pop up and ask you to select the source file path. Click OK to 

reverse. 

 

Note The function of Java Round-trip is only available for Professional Edition or above. 

C++ round-trip 

 

 To generate C++ for the whole project, click Tools from the menu bar, and select C++ Round-trip > 

Generate Code…. Generate code dialog box will be pop up and ask you to select a path, click + button to add 

a path. After selecting, click OK to generate. 

 To reverse class model from code, select Tools > C++ Round-trip > Reverse Code… from the main 

menu. Select source file path in the Reverse code dialog box and click OK to reverse. 

 

Note The function of C++ code round-trip is only available for Professional Edition or above. 
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Instant generator 

 

Instant generator produces source code from your model at a particular instant. Unlike the code generation support 

in round-trip engineering, instant generator is a one-off. To generate code, select Tools > Instant Generator from 

the main menu, then select the programming language to generate. 

   

Note The function of Instant generator is only available for Standard Edition or above. 

Instant reverse 

 

Instant Reverse allows you to reverse different types of source into UML class models, such as Java source, Java 

classes, C++ source etc. To reverse, select Tools > Instant Reverse from the main menu, then select the appropriate 

programming language. 

 

 

Note The function of Instant reverse is only available for Standard Edition or above. 
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Report Generation 

Generating report 

You can generate a report in form of HTML, PDF or Word from your project by clicking Tools and selecting 

Generate HTML/PDF/Word Report…. For example, select Generate PDF Report… if you would like to 

generate a PDF report. 

 

When the Generate PDF dialog box pops out, select the diagram(s) to be included in report. Fill in Output Path 

and click Generate to proceed with generation. 

 

Note The function of report generation is only available for Modeler Edition or above. 

Customizing report template 

You may customize the output by designing your own template instead of generating report with the built-in 

template. 

1. In the Generate PDF/ HTML/ Word dialog box, select New in the Template drop down menu. 

 

 

2. Report Template dialog box will subsequently pop out, type the name for your report template and start 

the editing. For example, click Add Diagram Loop below the name to create a loop of specific type(s) of 

diagram. 
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3. A tree will be revealed on the right hand side of the Report Template, select Use Case Diagram and click 

the green right arrow to insert it into the loop. 

 

4. Click Add Diagram Image icon on the left hand side of the Report Template, click the Add Element 

Summary on Diagram Loop (Use Case Diagram) icon to insert the summary table of the diagram. 

 

5. Select Use Case and other elements which you prefer to be included from the right hand side and press the 

right arrow to insert it to the included element list.  

6. Click the Add Property Column button from Element Summary (Use Case) to insert a property. Select 

Documentation from the right hand side and Documentation ${value} will automatically reveal on the 

left hand side. Click the Add Property Column Below icon on Documentation ${value}.  

 

 

7. Select Rank and Details.Author on the right hand side respectively following the steps mentioned above. 

8. After you have finished defining the template, click the Save button. You can then return to the Report 

Generation dialog box and select the template to generate report. 

 

Note The function of designing report template is only available for Standard Edition or above. 
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Publishing report to website 

1. You can publish your report to the website by selecting Tools > Project Publisher… from the main menu. 

 

2. Enter the output path in the Project Publisher dialog box and click OK to publish. 

3. It publishes the project, and opens the published content in web browser. You should see four tabs: 

Diagram Navigator, Model Explorer, Class Repository and Logical View on the left and your diagram on 

the right. Click the diagram on the left, it will be shown on the right screen.  
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4. You can click on a shape on an image to enter its detail page, for reading its properties. 

 

 

Note The function of publish report to website is only available for Standard Edition or above. 
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Teamwork collaboration 

Your team can work together on the same project effectively through the teamwork collaboration feature. VP-UML 

supports the integration with version control systems such as SVN, CVS, Perforce and Teamwork Server. In this 

section, we will cover basic setup of Teamwork Server, where SVN, CVS and Perforce users can skip, and basic 

teamwork operations with Teamwork Server. The techniques to be taught can be applied to the integration with 

SVN, CVS and Perforce, too. 

Note Teamwork Server is only available for Modeler Edition or above. 

SVN, CVS and Perforce integration are only available for Standard Edition or above. 

Installing and administrating teamwork server  

1. Download Teamwork Server at: 

http://www.visual-paradigm.com/download/vpts.jsp 

2. Check your Email account for the evaluation key of Teamwork Server. Save the key to your computer. 

3. Execute the Teamwork Server installer. 

 

4. Click Next in welcome page. 

5. In the License Agreement page, read through the agreement, select I accept the agreement if you agree 

with the terms. Click Next to proceed. 

6. Select a destination to install Teamwork Server. Click Next to proceed. 

7. Enter the name of Start Menu folder and click Next to proceed. 

8. In the Windows Services page, select whether or not to install Teamwork Server as service and click Next 

to proceed. 

9. In the Installation Type page, keep the option Server and Admin selected and click Next to proceed. 

10. In the Server Configuration page, scroll down to the part of License. Import the key you saved in step 2. 

Click Next to starting copying files. 

11. Instead of finishing here, we also need to perform administration tasks like to create users and projects. 

Click Start Server in the final page, and click Start Admin with browser. 

12. You should see the admin page being opened in web browser. Enter Admin for both name and password 

and click Login to login. 

 

13. Click on Add User. 

http://www.visual-paradigm.com/download/vpts.jsp
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14. In the Add User page, enter peter as name and password, click Add User. 

 

15. Click Add User again, enter john as name and password. Click Add User. 

16. Open the Projects tab. 

17. Click Add Project. 

18. In the Add Project page, enter My Project as project name. At the Project Users section at the bottom of 

page, select john and peter, and click Add as Read and Update. 

 

19. Click Add Project. 
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Login to server  

You can start working by logging into the Teamwork Client in VP-UML, manage, checkout and open the project. 

Manage project is to tell the client products that you are involved in a particular project. 

1. In VP-UML, select Tools > Teamwork > Open Teamwork Client... from the main menu. 

2. In the Login dialog box, enter 127.0.0.1 as server host, john as name and password (follow that defined in 

the last section). Click OK. 

 

3. In the Manage Project dialog box, select My Project and click > to manage it. Click OK to proceed. 
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Checkout and open project 

Checkout project is to download a managed project from server to your computer. Open project is to open the 

downloaded project in VP-UML. 

1. In the Teamwork Client dialog box, click Checkout at the bottom right corner of dialog box. 

 

2. Click Open Project. 
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Commit 

Commit refers to the process of uploading local modifications to server. 

Create a simple use case diagram as shown below: 

 

1. Select Tools > Teamwork > Commit... from the main menu to commit your changes to server. 

2. The Commit dialog box displays the changes to be committed to server. Click Next to proceed. 
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Update 

Update refers to the process of getting or downloading changes others have committed to server. 

1. Ask another team member to start VP-UML in his/her computer. 

2. Follow the steps as listed in the Login to server section to login to server as user peter. 

3. Checkout and open project My Project. 

4. Open the only use case diagram, and rename the use case 

 

5. Follow the steps as described in the Commit section to commit the change to server. 

6. Now, go back to john's environment.  

7. The Update dialog box displays the changes to be updated from server. Select Diagram > Use Case 

Diagram1 : UseCaseDiagram > Add a record : Use Case. Click Preview. This is to foresee the changes 

before actually updating it. In case the change is not desired, you may click Cancel to abort the process. 

Click OK. 

 

8. Check the use case. Its name has been changed to Add a record. 
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